Annonce

[15 février 2017] Publication de Wanewsletter 3.0.1

#1 2016-06-12 17:34:49

corentin.bcq-cznv
Membre
Inscription : 2016-06-12
Messages : 3

gros pb après maj du script

Bonsoir à toutes et tous,
je suis nouveau sur le forum et voici ma première question.
J'ai récemment mis à jour WaNewsLetter en version 3.0.0 et voici les problèmes rencontrés depuis :

impossible de me connecter.
Message d'erreur, ce jetton n'existe pas, quand je tente de réinitialiser mon mot de passe.
Et enfin message, no hacking, quand je tente de m'inscrire pour tester le script.

Que faire svp?

Merci beaucoup d'avance.

Hors ligne

#2 2016-06-13 12:59:38

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 274

Re : gros pb après maj du script

Bonjour,

Depuis quelle version avez-vous mis à jour ?
Votre navigateur autorise les cookies ?
Quelle URL appelez-vous quand vous obtenez le message "no hacking" ?
Comment est installé PHP sur le serveur ? mod_php apache ou fastcgi/php-fpm
Est-ce que vous utilisez une connexion https ?


PHP et MySQL, un duo gagnant !

Hors ligne

#3 2016-06-13 18:58:07

corentin.bcq-cznv
Membre
Inscription : 2016-06-12
Messages : 3

Re : gros pb après maj du script

Bonsoir,
j'ai mis à jour depuis une 2.3.4.

Oui j'utilise HTTPS mais ça fonctionnait très bien avant.
Comment est installé PHP j'en sais rien mais là encore ça fonctionnait parfaitement avant.

Enfin l'URL du script est :
https://www.accessibiliteprogrammes.fr/ … scribe.php

merci d'avance.

Hors ligne

#4 2016-06-13 19:52:47

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 274

Re : gros pb après maj du script

corentin.bcq-cznv a écrit :

Comment est installé PHP j'en sais rien mais là encore ça fonctionnait parfaitement avant.

Ça m'aiderait beaucoup d'avoir l'info smile

corentin.bcq-cznv a écrit :

En effet.
Éditez le fichier includes/common.inc.php. À la ligne 12, vous trouverez :

if (substr($_SERVER['SCRIPT_FILENAME'], -8) == '.inc.php') {
	exit('<b>No hacking</b>');
}

Remplacez par :

if (substr($_SERVER['SCRIPT_FILENAME'], -8) == '.inc.php') {
        echo $_SERVER['SCRIPT_FILENAME'];
        echo "<br>";
	exit('<b>No hacking</b>');
}

Et dites moi ce que ça affiche.
Je soupçonne un problème de configuration dans votre installation de PHP.


PHP et MySQL, un duo gagnant !

Hors ligne

#5 2016-06-14 07:17:47

corentin.bcq-cznv
Membre
Inscription : 2016-06-12
Messages : 3

Re : gros pb après maj du script

Bonjour,
ça affiche toujours no hacking smile sad

Hors ligne

#6 2016-06-14 12:56:20

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 274

Re : gros pb après maj du script

Ça ne peut pas afficher que "no hacking". Ça doit forcément afficher aussi le contenu de la variable $_SERVER['SCRIPT_FILENAME']

SCRIPT_FILENAME est une variable CGI qui indique le script en cours d'exécution (ce qui devrait être ici subscribe.php). Certains serveurs mal configurés ne définissent pas cette variable ou lui donne une valeur incorrecte.

edit: une autre explication pourrait être que vous n'avez pas remplacé tous les fichiers par ceux de la version 3.0.0. Vérifiez ce point.


PHP et MySQL, un duo gagnant !

Hors ligne

Pied de page des forums