Annonce

[15 février 2017] Publication de Wanewsletter 3.0.1

#1 2015-10-04 16:43:00

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 254

Publication de Wanewsletter 3.0-beta1

Bonjour à tous,

Je viens de publier la version 3.0-beta1 qui fait suite à la version 2.4-beta2, ceci pour une question de cohérence dans les numéros de version, compte tenu de l'importance des changements apportés au code source du script.

Les nouveaux pré-requis sont : PHP 5.4.4 minimum; base de données MySQL 5.0.7 minimum, PostgreSQL 8.3 minimum ou SQLite 3 et sont fixés jusqu'à la sortie de la version stable.
Par comparaison, la version 2.4-beta2 demandait PHP 5.3.7, MySQL 5.0.7, PostgreSQL 8.0 et supportait sqlite 2 en plus de sqlite 3.

Sachant que la branche 5.4 de PHP n'est plus supportée par l'équipe PHP officielle, ça semble raisonnable.

Au menu de cette version:

* Pré-requis de version PHP monté à 5.4.4
* Pré-requis de version PostgreSQL monté à 8.3
* Support complet de l'UTF-8
* Support SSL/TLS pour les connexions SMTP et POP
* Intégration de TinyMCE
* Suppression du support de SQLite 2
* Intégration de wamailer 4.0-dev en lieu et place de wamailer 2.5
* Gros travail de réécriture (ex: Espace de nom wanewsletter pour une meilleure intégration avec d'autres applications PHP)
* Utilisation de l’API password de PHP 5.5 + paquet ircmaxell/password-compat pour la compatibilité avec PHP 5.4
* Nouveau système de création/réinitialisation de mot de passe plus sécurisé
* Le module d'importation peut désormais traiter jusqu'à 10000 emails en une passe
* Nombreux bug fix


Téléchargement :
http://phpcodeur.net/wascripts/wanewsletter/telecharger

Changelog :
http://phpcodeur.net/wascripts/wanewsle … -3.0-beta1


PHP et MySQL, un duo gagnant !

Hors ligne

Pied de page des forums