Annonce

[15 février 2017] Publication de Wanewsletter 3.0.1

#1 2006-11-03 22:41:04

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Bonjour pour info j'informe le concepteur de son script avant fonctionné sous plesk 7.5 et que de nouveau fidele a son script je suis obligé de me tourné vers autre pour cause que le script ne fonctionne plus sous plesk 8.0 pourquoi je ne le sais pas. J'ai mon dedié et j'ai aucune interdiction en GD ou Safe Mod.

Si vous avez une solution a ce probleme je suis preneur car je ne trouverais jamais un aussi bon programme PHP.


Parole de webmaster et de concepteur amenageur de script.

Ps: installation Ok sans souci
Tables faites aussi, mais visualisation non visible apres mise en place et service


Serveur
PHP Version 5.0.4
MySQL Version 4.1.20
Plateforme Linux / Plesk 8.0 fr


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#2 2006-11-05 06:46:07

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : Derniere version 2.3 non compatible sous Plesk 8

Salut,

Qu'est-ce que Plesk et de quelle façon Wanewsletter y est-il intégré ?
Que signifie "ne fonctionne pas" ? Page blanche ? Message d'erreur ? Si oui, lequel ?


PHP et MySQL, un duo gagnant !

Hors ligne

#3 2006-11-05 14:59:54

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Bonjour,

Pesk est une gestion sous Linux ou Windows sur des serveurs dedié style Confix ou WebAdmin
Lien qui te montre ce que c'est que Plesk : http://www.amen.fr/static/index.php?pid=909

En faite Plesk 8 supporte tres mal les scripts (Mal écrit, pas a jour, etc..),  pourquoi je ne sais pas et j'ai cherché et pas trouvé de solution. de plus nous avons écrit au concepteur de Plesk et certaines corrections on été faite mais loin d'y finir.

Depuis que nous sommes sous Plesk 8 obligé de mettre le serveur en PHP 5. Beaucoup de nos scripts font l'objet de modification a cause a cause de ceci et non supporté en php5.


C'est pour cela que je me demande si votre script supporte php5 ou des corrections sont tel prevu pour en faire l'objet.

Nous avons utilisé votre Script pendant des mois et des mois voir 1 an 1/2 déjà et jamais de souci sous php4 et plesk 7 et 7.5

Actuellement votre script n'est pas visible que sous une page blanche.
Nous y regardons dans la limite de nos temps perdu mais c'est pas gagné.
D'ou la raison de notre info sur votre forum et que peut être quelqu'un a la solution et qui aurait été dans le même cas que moi.

PS: La mise en place, chomd, l'instal tout est Ok sans souci
Le choix du login et passe admin aussi, création des tables aussi sans bug, mais apres la fin de l'instal, setup viré du serveur, le script en lui même n'est pas visible n'y la partie admin et sans motif d'erreur.

Voila pour les infos et qui peut être servira a d'autre comme moi sous un serveur dédié en Plesk 8 et PHP 5


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#4 2006-11-05 16:22:16

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Rebonjour ayant passé une bonne partie de la nui je vous informe qu'il ne faut surtout pas faire de modif dans le script du concepteur, mais avoir si vous êtes sous PLESK 8 et PHP 5 de ne mettre a jour que PHP5 derniere version sur votre serveur DEDIE et PHP5 et le tout rentre dans l'ordre.

Donc mes excuses vers le concepteur du script si celui ci cherche des solutions et qu'il n'y a pas lieu d'en faire pour qu'il fonctionne.

Parcontre, que le script est en place, j'ai testé une inscription et tout passe correctement sauf un bug que je constate quand on reçoit le mail pour confirmé sa demande et que l'on clique sur le lien pour le validé la passe s'ouvre et nous dit que le code est invalide pourquoi ?

Malgré tout l'inscription se fait quand meme en arriere plan, mais a l'ecran on voit ce message.

Inscription   Changer de format   Désinscription

Code invalide !


En cas faire le test ici pour voir l'erreur: http://www.carte4you.com/mailinglist/subscribe.php

Version du script 2.3.1


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#5 2006-11-07 04:02:00

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : Derniere version 2.3 non compatible sous Plesk 8

Je me suis inscrit et j'ai bien obtenu le message me disant qu'un email de confirmation m'a été envoyé.

En cliquant sur le lien dans l'email de confirmation, je tombe bien sur le formulaire avec le message "Votre inscription a été confirmée !".


PHP et MySQL, un duo gagnant !

Hors ligne

#6 2006-11-07 09:10:16

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Oui je suis d'accord avec toi que l'inscription se fait.
Mais quand tu reçois le mail et que tu cliques dessus sa dit bien Code Invalide. C'est la toute l'erreur du script.

Pour Mieux comprendre j'ai fait les 3 etapes en image pour que tu vois au mieux le souci que je t'indique.

1 - La demande d'inscription = Ok
2 - Le mail de confirmation =  Ok mais je pense que le code y manque quelque chose comme le mail a la fin mais pas sur. Enfin si je clique dessus la confirmation se fait mais a vrai dire on le sait pas car c'est pas confirmé a l'ecran a cause de l'erreur " Code Invalide "
3 - Celle ci montre que malgré que nous avons cliqué sur le lien du mail Dit bien Code Invalide.

C'est ici qu'il y a l'erreur.

Soit dans le mail le lien est imcomplet soit un autre souci quelque part
Lien du mail: Afin de confirmer votre inscription, cliquez sur le lien ci dessous :
http://www.carte4you.com/mailinglist/su … 650451cd46

Un truc du style Email apres la portion de code, je sais pas je dit ceci simplement.

http://www.carte4you.com/codeur/Image1.jpg

http://www.carte4you.com/codeur/Image2.jpg

http://www.carte4you.com/codeur/Image3.jpg


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#7 2006-11-09 04:01:47

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : Derniere version 2.3 non compatible sous Plesk 8

Oui je suis d'accord avec toi que l'inscription se fait.
Mais quand tu reçois le mail et que tu cliques dessus sa dit bien Code Invalide. C'est la toute l'erreur du script.

Non, quand je clique sur le lien de confirmation, ça me dit "Votre inscription a été confirmée !". Et j'ai testé sur votre formulaire.

Est-ce que vous faites ce test avec une adresse email déjà inscrite dans la base de données (inscrite à une autre liste) ?


PHP et MySQL, un duo gagnant !

Hors ligne

#8 2006-11-09 08:58:09

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Je crois que l'on ne se comprend pas.

Regarde la 3 eme image Il y a bien marqué Code Invalide!

C'est ce ceci que je parle.

Le message s'affiche quand tu cliques sur le lien de la boite email pour confirmé ton inscription.

Si l'image affiche Code Invalide c'est qu'il y a bien un souci de mon côté je pense.

Exemple: tu reçois l'email pour confirmé ton inscription, On devrait plutot voir comme message Votre inscription est bien confirmé a la derniere etape et non  Code Invalide. La personne qui voit se message se dit qu'il y a une erreur et recommence comme la dit une personne avant hier.

Il ma fait parvenir un mail pour me dire que le code du lien qu'il a reçu n'est pas valide, alors que l'inscription c'est bien faite.


Regarde bien la derniere image c'est celle ci la plus importante.


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#9 2006-11-09 20:09:01

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Re, j'ai créé une autre liste de News sous le nom de test d'envoi et j'ai toujours le même souci que l'image 3 que j'ai mit en lien.

Donc je ne comprend toujours pas d'ou vient le souci.


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#10 2006-11-09 21:40:38

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : Derniere version 2.3 non compatible sous Plesk 8

Je crois que l'on ne se comprend pas.

Non, c'est vous qui ne comprenez pas.
J'ai fait le test sur votre propre formulaire, avec mon adresse email.
Quand je clique sur le lien de confirmation, je tombe sur le formulaire avec le message "Votre inscription a été confirmée !".
Je ne l'invente pas ça.

Je suis tout disposé à croire que de votre coté, vous obtenez le message "Code invalide!".
Le but est donc de savoir exactement dans quelle circonstance se produit ce bug. À partir de là, si j'arrive à reproduire le bug chez moi, je pourrai sans peine le corriger.

Donc j'attends toujours une réponse à cette question:

Est-ce que vous faites ce test avec une adresse email déjà inscrite dans la base de données (inscrite à une autre liste) ?


PHP et MySQL, un duo gagnant !

Hors ligne

#11 2006-11-09 23:48:06

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Apres une longue conversation avec Bobe a mon sujet, Tout est rentré dans l'ordre, pourquoi ?
- Bien lui comme moi ne le savons pas.

Une erreur du Script ?
- Non rien avoir, c'est pas le script en lui même qui est concerné.

Solution...
Bien on a juste fait un léger passage sur un fichier et remit en état normal en finale et tout refonctionne.


Pour mon compte nous avons passé de très grandes minutes a cherché pourquoi j'avais ce message, et au final sa refonctionne.

Encore un grand merci au concepteur " Wanewsletter " Bobe pour son aide, patience car rare qu'un programmateur donne de son temps en dehors de son site ou forum pour trouvé une solution.

Mille Merci encore Bobe.

Sa le mérite d'être dit ici.


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#12 2006-11-10 15:27:37

Soli
Membre
Inscription : 2006-11-10
Messages : 4

Re : Derniere version 2.3 non compatible sous Plesk 8

Bonjour, je suis aussi hebergé chez Amen, et mon hebergement vient de migrer sur les nouveaux serveurs.
Ma version 2.2.5 de Wanewsletter ne fonctionne plus, alors j'ai tout jeter et j'ai fais une reinstallation complete de la version 2.3.1.

L'installation s'est déroulée sans problemes, sauf si on supprime le dossier setup, apres l'install... ça ne fonctionne plus . ALors j'ai remis le dossier setup.

le formulaire d'inscription et deinscription est OK, par contre c'est l'envoi de newsletter qui me pose un probleme :

je fais un  envoie a une liste d e 239 abonnés, et j'obtiens le message suivant :

Impossible de mettre à jour la table des abonnés (connexion au serveur sql perdue)

SQL query :
UPDATE NL_abo_liste
SET send = 1
WHERE abo_id IN(1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103, 104, 105, 106, 107, 108, 109, 110, 111, 112, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 126, 127, 128, 129, 130, 131, 132, 133, 134, 135, 136, 137, 138, 139, 140, 141, 142, 143, 144, 145, 146, 147, 148, 149, 150, 151, 152, 153, 154, 155, 156, 157, 158, 159, 160, 161, 162, 163, 164, 165, 166, 167, 168, 169, 170, 171, 172, 173, 174, 175, 176, 177, 178, 179, 180, 181, 182, 183, 184, 185, 186, 187, 188, 189, 190, 191, 192, 193, 194, 195, 196, 197, 198, 199, 200, 201, 202, 203, 204, 205, 206, 207, 208, 209, 210, 211, 212, 213, 214, 215, 216, 217, 218, 219, 220, 221, 222, 223, 224, 225, 226, 227, 228, 229, 230, 231, 232, 233, 234, 235, 236, 237, 238, 239)
AND liste_id = 2

SQL errno : 2006
SQL error : MySQL server has gone away

Fichier : engine_send.php Ligne : 633

je retourne ensuite dans le menu "envoi /liste des envois en cours"

je trouve ma NL avec comme choix "reprendre ou annuler".
si je fais "reprendre", j'ai le message habituel : votre newsletter a été envoyé à 293 abonnés.."
mais elle n'a pas été envoyée !!!!!

Avez-vous une solution à ce probleme?
JE dois avouer que mon niveau en programmation frise le niveau O.. je suis graphiste!!!
alors j'ai posé la questin au support technique chez AMEN qui m'a répondu ceci :
Il faut que votre script comporte une pause dans la boucle d'envoi (x secondes de pause tout les x envois traités).

Merci d'avance

Hors ligne

#13 2006-11-10 22:02:05

Mygale
Membre
Lieu : France
Inscription : 2003-01-14
Messages : 66
Site Web

Re : Derniere version 2.3 non compatible sous Plesk 8

Soir qui a parlé que j'étais hebergé chez AMEN ?

Moi pas chez eux, j'ai mon propre serveur dédié.


Pour ton cas seul bobe peux dire car je pense qu'il faut mettre des echo sur un ou plusieurs fichiers pour l'envoi.

Donc pour éviter de dire des conneries, Je préfere qu'il te répondre.


Les services GRATUITS du Web
maxdeson.com
carte4you.com

Hors ligne

#14 2006-11-13 12:46:15

Soli
Membre
Inscription : 2006-11-10
Messages : 4

Re : Derniere version 2.3 non compatible sous Plesk 8

Rebonjour,

Désollé, comme tu as mis le lien http://www.amen.fr/static/index.php?pid=909
j'ai pensé que tu étais hébergé chez Amen

Hors ligne

Pied de page des forums