Annonce

[15 février 2017] Publication de Wanewsletter 3.0.1

#1 2005-11-25 19:14:59

christobal
Membre
Inscription : 2004-06-24
Messages : 32

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Bonjour en voulant mettre à jour la version 2.2.7 en 2.2.8 j'ai eu l'erreur suivante :

Parse error: parse error, unexpected '&', expecting T_VARIABLE or '$' in functions.php on line 639

comment corriger l'erreur.

Merci

Hors ligne

#2 2005-11-25 19:33:43

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

En prenan soin d'uploader les fichiers sur votre serveur FTP en mode ASCII (sauf les images).


PHP et MySQL, un duo gagnant !

Hors ligne

#3 2005-11-25 19:50:10

Daktari
Membre
Lieu : Belgique
Inscription : 2005-10-02
Messages : 5
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Même erreur  :cry: et je ne vois pas comment télécharger en ASC II à partir de filezilla ?

Hors ligne

#4 2005-11-25 19:51:45

christobal
Membre
Inscription : 2004-06-24
Messages : 32

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

L'upload a été faite correctement, même 2 fois.
Je suis géné car il va faloir que j'envoie une News la semaine prochaine.
En utilisant le fichier fonctions.php de la version précédente la MAJ a été  possible.
Ai je bien fait ?
Si non pourrai je avoir une aide pour corrige le PB du fichier fonctions.php de la version 2.2.8

Merci

Hors ligne

#5 2005-11-25 19:52:55

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Même erreur  :cry: et je ne vois pas comment télécharger en ASC II à partir de filezilla ?

tu cliques sur transfert->type de transfert-> mode ascii mais ça ne change rien y a toujours le même message.

Hors ligne

#6 2005-11-25 19:57:43

Daktari
Membre
Lieu : Belgique
Inscription : 2005-10-02
Messages : 5
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Exact ça ne va pas non plus, j'ai remis les fichiers de l'ancienne version en attendant...

Hors ligne

#7 2005-11-25 19:58:39

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Ok, ok, c'est une grosse boulette de ma part. Je viens de me rendre compte d'une incompatibilité avec PHP4 (je bosse sous PHP5).

Les archives ne sont plus accessibles jusqu'à que je développe une solution alternative (comptez quelques minutes à une heure maxi).

Pour les personnes interessées, j'utilise un passage de variable par référence dans une boucle foreach() et je n'ai pas imaginé une seconde que cela ne soit pas possible en PHP4.

Toutes mes excuses.


PHP et MySQL, un duo gagnant !

Hors ligne

#8 2005-11-25 19:59:14

mussara
Membre
Inscription : 2005-11-17
Messages : 26
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

en attendant la correction de ce pb, le mieux est de remettre en ligne la sauvegarde de la version précédente...

Hors ligne

#9 2005-11-25 20:04:22

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Ok, ok, c'est une grosse boulette de ma part. Je viens de me rendre compte d'une incompatibilité avec PHP4 (je bosse sous PHP5).

Les archives ne sont plus accessibles jusqu'à que je développe une solution alternative (comptez quelques minutes à une heure maxi).

Pour les personnes interessées, j'utilise un passage de variable par référence dans une boucle foreach() et je n'ai pas imaginé une seconde que cela ne soit pas possible en PHP4.

Toutes mes excuses.

L'erreur est humaine  wink
On attend sagement la mise à jour

@+

Hors ligne

#10 2005-11-25 20:16:40

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Le problème est résolu et les archives de nouveau en ligne.
Désolé pour la gène occasionnée.

edit: Je deviens un peu parano par contre, donc si on pouvait me confirmer que le problème est effectivement réglé  :grin2:


PHP et MySQL, un duo gagnant !

Hors ligne

#11 2005-11-25 20:21:08

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Le problème est résolu et les archives de nouveau en ligne.
Désolé pour la gène occasionnée.

edit: Je deviens un peu parano par contre, donc si on pouvait me confirmer que le problème est effectivement réglé  :grin2:

Ok je test ça de suite

Hors ligne

#12 2005-11-25 20:24:53

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

L'installation a priori est ok !
Je dis "installation" car vu que j'avais tout viré pensant que c'était chez moi qu'il y avait un bug.

Hors ligne

#13 2005-11-25 20:29:03

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

arf, que faire quand on a ça

Erreur !Une erreur s'est produite durant l'installation.

L'erreur est : Table 'wa_abo_liste' already exists
La requète est : CREATE TABLE `wa_abo_liste` ( `abo_id` mediumint(8) unsigned NOT NULL default '0', `liste_id` tinyint(3) NOT NULL default '0', `format` tinyint(1) NOT NULL default '0', `send` tinyint(1) NOT NULL default '0', PRIMARY KEY (`abo_id`, `liste_id`)) TYPE=MyISAM

Merci d'avance

Hors ligne

#14 2005-11-25 20:33:34

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Wanewslette est déjà installée. Vous avez probablement supprimé également le fichier includes/config.inc.php ce qui explique que Wanewsletter tente une installation au lieu de proposer une mise à jour.

Éditez ce fichier et placez-y ceci:

<?php

//
// Paramètres d'accés à la base de données
// Ne pas modifier !
//
define('NL_INSTALLED', true);

$dbtype     = "mysql";

$dbhost     = "localhost";
$dbuser     = "dbuser";
$dbpassword = "dbpassword";
$dbname     = "wandb";

$prefixe    = "wa_";

?>

En renseignant correctement les variables pour l'accès de Wanewsletter à la base de données.
Wanewsletter devrait ensuite vous proposer de faire la mise à jour (laquelle, outre le remplacement des fichiers sur le serveur, se résume à incrémenter le numéro de version).


PHP et MySQL, un duo gagnant !

Hors ligne

#15 2005-11-25 20:40:57

mussara
Membre
Inscription : 2005-11-17
Messages : 26
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

je confirme que la mise à jour 227 -> 228 se passe très bien désormais (en n'oubliant le fameux fichier de config à conserver dans includes + stats + upload)

merci à toi Bobe

reste à tester l'envoi de news... wink

Hors ligne

#16 2005-11-25 20:51:58

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Je n'ai pas fait de modifications sur la partie envoi proprement dit, et j'ai déjà fait un envoi (pour annoncer wanewsletter 2.2.8) avec donc tout est ok :¬)


PHP et MySQL, un duo gagnant !

Hors ligne

#17 2005-11-25 20:52:02

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Wanewslette est déjà installée. Vous avez probablement supprimé également le fichier includes/config.inc.php ce qui explique que Wanewsletter tente une installation au lieu de proposer une mise à jour.

Éditez ce fichier et placez-y ceci:

<?php

//
// Paramètres d'accés à la base de données
// Ne pas modifier !
//
define('NL_INSTALLED', true);

$dbtype     = "mysql";

$dbhost     = "localhost";
$dbuser     = "dbuser";
$dbpassword = "dbpassword";
$dbname     = "wandb";

$prefixe    = "wa_";

?>

En renseignant correctement les variables pour l'accès de Wanewsletter à la base de données.
Wanewsletter devrait ensuite vous proposer de faire la mise à jour (laquelle, outre le remplacement des fichiers sur le serveur, se résume à incrémenter le numéro de version).

Merci Bobe c'est nickel  smile

Hors ligne

#18 2005-11-25 20:55:56

christobal
Membre
Inscription : 2004-06-24
Messages : 32

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Ayant initier le post je confirme que tout est OK

Merci pour la réactivité.

Hors ligne

#19 2005-11-25 20:56:23

mussara
Membre
Inscription : 2005-11-17
Messages : 26
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

par contre j'essaie de créer un nouveau abonné, mais je n'ai pas de mail qui arrive (bien que l'activation par email soit activée...)  neutral

Hors ligne

#20 2005-11-25 21:16:10

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Pas de changement non plus sur cette partie par rapport à la version 2.2.7 (sauf le bug de non-mise à jour des statistiques mais ça n'impacte pas sur l'envoi de l'email). Peut-être un embouteillage sur les serveurs smtp ?


PHP et MySQL, un duo gagnant !

Hors ligne

#21 2005-11-25 21:20:50

mussara
Membre
Inscription : 2005-11-17
Messages : 26
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

oui tous les mails viennent d'arriver en cascade à l'instant... désolé

au fait merci de me confirmer que l'install ds le cadre d'une mise à jour ne modifie que le "numéro" de la  version 2.2.7 -> 2.2.8 (et bien entendu les modifs au niveau des fichiers), donc qu'en gros que la BD n'est pas modifiée

Hors ligne

#22 2005-11-25 21:26:02

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 289

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

au fait merci de me confirmer que l'install ds le cadre d'une mise à jour ne modifie que le "numéro" de la  version 2.2.7 -> 2.2.8 (et bien entendu les modifs au niveau des fichiers), donc qu'en gros que la BD n'est pas modifiée

Aucune modification de la structure des tables n'intervient à partir du moment où une branche est déclarée stable.
Le seul changement est pour le contenu de la colonne 'version' dans la table *_config.


PHP et MySQL, un duo gagnant !

Hors ligne

#23 2005-11-25 21:39:55

Daktari
Membre
Lieu : Belgique
Inscription : 2005-10-02
Messages : 5
Site Web

Re : [Résolu] Erreur lors de la MAJ vers 2.2.8

Tout est ok pour l'installation  :grin2: . Merci  smile .

Hors ligne

Pied de page des forums