Annonce

[15 février 2017] Publication de Wanewsletter 3.0.1

#1 2004-05-19 10:07:45

gigi trial
Membre
Inscription : 2004-05-19
Messages : 2

Re : Fichier : engine_send.php Ligne : 202

Bonjour à tous, tout d'abord bravo !
J'ai installé WAnewsletter, chez amen sur un serveur mutualisé... marchait pas sad
Alors je l'ai installé sur notre propre serveur, et voici ma config :

WAnewsletter 2.2.3

- serveur Linux
- php 4.3.1
- option smtp activée
- g testé avec les deux moteurs d'envoi : envoie en copie cachée et 1 email par abonné

Lorsque je fais un test avec 3 ou 4 adresse email, aucun soucis, tout ce passe très bien, par contre lorsque que ma liste contient 3500 email. ça ne passe pas. (G essayez en modifiant les flots etc..) rien n'y fait.

J'ai ce message d'erreur:

L'email n'a pu être envoyé ! send_data() :: 501 Bad address syntax
Fichier : engine_send.php Ligne : 202

merci d'avance

guillaume

Hors ligne

#2 2004-05-20 21:25:35

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 266

Re : Fichier : engine_send.php Ligne : 202

hum..

Dans le fichier class.smtp.php, mettez la propriété save_log à TRUE:

var $save_log       = TRUE;

et refaites un essai. En suite regardez les dernières lignes dans le fichier log_smtp.txt qui aura été généré dans le dossier admin/ pour voir l'adresse email qui pose problème (et me l'indiquer).


PHP et MySQL, un duo gagnant !

Hors ligne

#3 2004-05-23 15:51:10

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 266

Re : Fichier : engine_send.php Ligne : 202

Bien, éditez le fichier class.mailer.php et cherchez à la ligne 1788:

if( WM_PHP_VERSION >= 40005 && empty($safe_mode) )
{
    $result = @mail($address, $subject, $message, $headers, '-f' . $Rpath);
}
else
{
    $result = @mail($address, $subject, $message, $headers);
}

remplacez par :

$result = @mail($address, $subject, $message, $headers);

Ça donne quoi ?

edit: finalement vous utilisez l'option smtp (comme vous le dites dans votre premier message) ou pas ?

edit 2: Je confirme que la modification ci-dessus semble résoudre le problème.


PHP et MySQL, un duo gagnant !

Hors ligne

#4 2004-05-23 16:26:48

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 266

Re : Fichier : engine_send.php Ligne : 202

Bon, je suis en train de faire des tests. La directive safe_mode de php n'est pas accessible sur les serveurs de free mais le safe mode semble néanmoins activé...

C'est génant ça.

(En gros, le test du if() du code ci dessus se vérifie mais ne devrait pas, merci free et sa config exotique)


PHP et MySQL, un duo gagnant !

Hors ligne

#5 2004-05-24 07:54:06

gigi trial
Membre
Inscription : 2004-05-19
Messages : 2

Re : Fichier : engine_send.php Ligne : 202

Merci je vais tester en faisant cette modif, bcps de gens semble rencontrer des problèmes sur amen, non ?

Hors ligne

#6 2004-05-24 16:16:00

Bobe
Administrateur
Lieu : La Rochelle
Inscription : 2002-05-27
Messages : 5 266

Re : Fichier : engine_send.php Ligne : 202

Merci je vais tester en faisant cette modif, bcps de gens semble rencontrer des problèmes sur amen, non ?

Euh, mes messages répondaient à la personne en invité. Je n'ai pas fait attention aux pseudos, apparamment, vous êtes deux personnes différentes.

Le problème est peut être similaire sur amen. Le safe mode de php y est il activé ?


PHP et MySQL, un duo gagnant !

Hors ligne

#7 2004-09-17 10:43:04

info-groupe
Membre
Lieu : Rennes (35 - Ille et Vilaine)
Inscription : 2003-11-23
Messages : 9
Site Web

Re : Fichier : engine_send.php Ligne : 202

:idea: Après avoir résolu votre bug, n'oubliez pas de remettre :

var $save_log       = FALSE;

car le fichier créé log_smtp.txt devient vite très volumineux. Dans mon cas, je m'en étais pas aperçu tout de suite mais il faisait 328 748 ko !! Joli score pour un fichier .txt !!  yikes

A bientôt.
Thierry


http://www.info-groupe.com - Annuaire des groupes musicaux

Hors ligne

#8 2005-05-16 13:57:23

Kik
Membre
Inscription : 2005-04-11
Messages : 26

Re : Fichier : engine_send.php Ligne : 202

Merci je vais tester en faisant cette modif, bcps de gens semble rencontrer des problèmes sur amen, non ?

Bonjour,
J'ai le même défaut sur un serveur mais pas hébergé chez free  neutral

Hors ligne

Pied de page des forums